Incident

BT Call Drops

Closed | Dec 10, 2025 | 21:03 GMT+00:00

We wanted to provide a final update on this incident before marking it as closed. BT have been liaising with their network vendor and have full details regarding the cause of the problems. It has been confirmed that the issue was the result of a software bug on some core network equipment which is in the path of our voice traffic.

BT currently have a workaround for the problem and are in the process of scheduling network maintenance to upgrade the respective network equipment.

Apologies for the delay in closing this incident whilst we waited for details from BT. We appreciate how disruptive incidents like this can be for your business and would like to apologize for the inconvenience caused.

Affected components

  • Voice Platform

Monitoring | Dec 03, 2025 | 10:00 GMT+00:00

The voice platform has remained stable since our previous update. We are currently in discussion with BT and are awaiting a detailed Reason for Outage (RFO).

This incident will remain in a monitoring state for the time being, thanks.

Waiting | Dec 01, 2025 | 09:10 GMT+00:00

This incident remains open as we continue to work with BT. We have seen no disruption to service since our last update on Friday at 10:45.

All monitoring metrics are currently showing as stable.

Investigating | Nov 28, 2025 | 11:53 GMT+00:00

The current status of this incident is that we experienced 2 drops for active calls this morning.

1st drop at 10:38
2nd drop at 10:45

BT have acknowledged an issue on their side and have also confirmed that other customers have reported issues. Their network team are currently troubleshooting the issue as a priority.

Since 10:45 traffic has been stable.

Investigating | Nov 28, 2025 | 10:48 GMT+00:00

Based on our investigation we believe BT are experiencing overall problems. Other BT services are being reported as troublesome at this time.

https://downdetector.co.uk/

Apologies for the inconvenience as we work through this issue.

Investigating | Nov 28, 2025 | 10:33 GMT+00:00

In addition to the call drops we are also receiving a number of reports regarding poor call quality.

This is actively being investigated with BT and we are also confirming any actions that can be taken from our side to mitigate the issue.

Investigating | Nov 28, 2025 | 10:24 GMT+00:00

From our monitoring we have just seen a drop in active inbound calls from BT. We are speaking with BT as we believe this to be related to the issues the other day. If you experience any issues please contact our support team who can take a note of your example.

Apologies for the inconvenience caused.

Monitoring | Nov 27, 2025 | 13:13 GMT+00:00

We received an update from BT this morning to say they believe the issue was resolved yesterday at 15:49.

Actions were taken by one of their network vendors and they also reseated various SFP (Small Form-Factor Pluggable) modules in their network devices.

We are currently monitoring the situation. If you experience any call drop issues please contact our support team. Thank you.

Investigating | Nov 26, 2025 | 12:44 GMT+00:00

At 12:38 we experienced another drop on our link to BT.

As we managed to catch the drop before it came back up we have temporarily shut down the link to avoid the link flapping.

This should improve the situation as traffic will no longer route via the problematic link until we manually enable it again.

We will continue to update the incident as we have new updates.

Waiting | Nov 26, 2025 | 12:21 GMT+00:00

We have just experienced a drop with our connection to BT at 12:12 which would have resulted in dropped calls.

We have reported this to BT to make them aware.

Apologies for the inconvenience caused.

Waiting | Nov 26, 2025 | 09:22 GMT+00:00

BT have acknowledged the issue on their side as of 09:06 this morning. They have confirmed they have engineers in Telehouse (the affected data centre location) investigating the issue.

This means our connection with BT should still be considered a risk; however, we have not seen any call drops since yesterday at 16:52.

We will continue to liaise with BT as a priority and we are expecting the next update in 2 hours.

Waiting | Nov 25, 2025 | 19:21 GMT+00:00

Our ticket with BT remains open at this time. They have not confirmed an issue however they did let us know they had received a larger number of calls compared to usual.

We will continue to investigate with BT and provide an update in due course.

Since 16:52 there have not been any call related issues.

Investigating | Nov 25, 2025 | 17:01 GMT+00:00

We are currently investigating reports of intermittent call drops via our main carrier BT.

We have seen multiple (3) connection drops to BT since 16:16 this afternoon.

An urgent ticket has been raised with BT.