Closed | Jul 02, 2024 | 16:38 GMT+01:00
We would like to provide a final update before we consider this incident closed. On 20 June 2024 we received several reports from users across the platform that were experiencing issues when logging into the Unity software. After an initial investigation it was determined that Cloudflare was incorrectly dropping legitimate traffic.
All inbound traffic to our core network is protected by Cloudflare. This is achieved by having Cloudflare advertise the IP addresses we own to the internet on our behalf. By doing this it means all traffic is first sent to Cloudflare and analyzed before it is forwarded onto our own network. Cloudflare are setup to protect us from many common attack vectors by default.
Once we had determined that Cloudflare were the cause of the Unity issues we took the decision to modify our configuration so that Unity login traffic would come straight to our network instead of first going to Cloudflare. This configuration change consists of us modifying our Cloudflare setup, so they are no longer advertising a specific range of IP addresses on our behalf.
In the past it has been possible to make such a change during working hours, however, this time when the internet routing reconverged to its new route it resulted in a brief period of dropped traffic for some users. Going forward we will not make such a configuration change during working hours unless necessary.
We have been working with Cloudflare to ensure we are able to resolve similar issues in the future without having to modify our routing configuration. These methods would not impact service in any way.
We will reverse the routing configuration change with Cloudflare this evening (2 July 2024) to ensure our core network remains protected. We would like to apologize for any inconvenience caused during this incident and have changes in place now to ensure this doesn’t happen again.
Resolved | Jun 20, 2024 | 12:07 GMT+01:00
This incident was resolved at approximately 11:01 this morning.
To resolve this issue we needed to implement a network routing change. A small numbers of users may have experienced brief connectivity issues at around 10:58. Apologies for any disruption.
We will continue to monitor the situation and are working with one of our vendors regarding the requirement for the network routing change.
A final update will be provided before we consider this incident closed.
Investigating | Jun 20, 2024 | 10:35 GMT+01:00
We are currently investigating an issue where some users are experiencing issues when logging into Unity.
This issue seems to be affecting a minority of users but we are investigating urgently.