Incident

Call2Teams issues

Closed | Apr 19, 2026 | 13:34 GMT+01:00

Since the fix was implemented we have been monitoring the platform to ensure no further instances of this issue have occurred. We can confirm that the fix implemented by Call2Teams has resolved the issue. Apologies for the inconvenience caused during this incident.

Affected components

  • Teams Calling via Call2Teams

Resolved | Apr 15, 2026 | 14:47 GMT+01:00

A fix for this problem has been deployed and tested. We will monitor for the next 24 hours and this incident will remain open. Apologies for any inconvenience caused.

Resolution in progress | Apr 15, 2026 | 11:51 GMT+01:00

Call2Teams have identified a workaround that they are currently testing with a small number of customers. If all looks OK this will be rolled out across the board. We are expecting an update within the next 2 hours. Thanks for your understanding.

Investigating | Apr 15, 2026 | 10:50 GMT+01:00

We are aware of intermittent issues affecting our Microsoft Teams Calling integration via Call2Teams. We are currently speaking with the supplier to establish the situation and any potential workaround options. If you experience any issues with making calls using Microsoft Teams please give the support team a call.