Closed | Nov 21, 2024 | 15:48 GMT+00:00
We wanted to provide a final update before marking this incident as closed. On 13 November at around 09:00 we began to receive reports of inbound calls failing. Our team immediately began investigating and quickly discovered the issue was specific to inbound calls being presented to Webex mobile devices.
Calls presented to Webex mobile are done via push notifications from either Apple (iOS) or Google (Android). A ticket was raised with Cisco and at around 11:00 it was established that the issue was being caused by a delay in DNS responses from Cisco. DNS is used to translate human friendly names to internet addresses. As a workaround we hard coded these internet addresses on our side to bypass the DNS request, thus avoiding the chance of any delay.
This workaround remains in place until Cisco confirm they are satisfied the issue will not happen again. In addition to this we are also waiting on a patch from Cisco which will ensure any future DNS delay is handled more gracefully.
We are in continued contact with Cisco on this matter until all outstanding actions are complete. From an incident perspective we can consider this matter closed as things are stable and fully operational.
Please accept our apologies for the inconvenience caused by this incident.
Monitoring | Nov 14, 2024 | 10:08 GMT+00:00
The temporary fix which was implemented continues to work and we are continuing to monitor the situation. Cisco have confirmed that they are investigating a DNS related issue on their side which is the root cause. The incident will remain open but the status of Webex can be considered fully operational.
Monitoring | Nov 13, 2024 | 11:13 GMT+00:00
We have implemented a potential fix and inbound calls are now being presented to Webex mobile as usual. We will continue to monitor the situation and provide an update later today.
Investigating | Nov 13, 2024 | 10:50 GMT+00:00
We are continuing to investigate this issue and have been actively troubleshooting with the respective vendor. Apologies for the inconvenience caused.
Investigating | Nov 13, 2024 | 09:43 GMT+00:00
We are aware of an issue where inbound calls are not being received by Webex mobile. This is currently being investigated as a priority by the team.